Current location: >

x737 patch for X-Plane 940RC6+ patched

Old plugin version caused conflicts

Due to a version conflict in the patch that should make x737 compatible with X-Plane 940RC6 we had to upload it again today in an updated version. All users who have installed it are strongly encouraged to reload it and install the patch again. Furthermore all users participating in the X-Plane 940 beta program should update although the x737 aircraft run fine with X-Plane 940RC9 because the plugin fixes some minor issues reported by users.
copyright © 2018 x737project • About x737project | Privacy • Made with phpwcms Content Management System